[Samba] Failed rpmbuild-ing samba-3.0.32.tar.gz

FC Mario Patty fcmario76 at gmail.com
Sun Nov 9 09:01:52 GMT 2008


Relating to my emails before (SAMBA & SOLIDWORS : cat & dog?) now I've been
trying to update my samba-3.0.10 to samba-3.0.32 . I downloaded the source
form samba.org and trying to create rpm package from one. I created
~/.rpmmacros file

%_tmppath /home/fcmario/tmp
%_topdir /home/fcmario/src/rpm
%prefix /usr/local

and ran

% rpmbuild -ta ~/src/rpm/SOURCES/samba-3.0.32.tar.gz

I got error messages that it cannot cd to lsb-samba-2.2.1.tar.gz. I go to
~/src/rpm/SPECS and edited lsb-samba.spec to become

Summary: SAMBA
Name: samba                        # the old phrase was lsb-samba
Version: 3.0.32                      # the old phrase was 2.2.1
Release: 0

# More lines here

export LDFLAGS="-L/usr/lib/lsb --dynamic-linker=/lib/ld-lsb.so.1"

./configure --with-fhs  --prefix=/usr --sysconfdir=/etc \
            --sharedstatedir=/var --datadir=/usr/share \
#            --with-swatdir=/usr/share/samba/swat
# More lines here

then rename lsb-samba.spec to samba.spec. Once again I ran

% rpmbuild -ba ~src/rpm/SOURCES/samba.spec

It came out with error messages

Executing(%build): /bin/sh -e /home/fcmario/tmp/rpm-tmp.457
+ umask 022
+ cd /home/fcmario/src/rpm/BUILD
+ cd samba-3.0.32
+ export LANG
+ unset DISPLAY
+ export 'LDFLAGS=-L/usr/lib/lsb --dynamic-linker=/lib/ld-lsb.so.1'
+ LDFLAGS='-L/usr/lib/lsb --dynamic-linker=/lib/ld-lsb.so.1'
+ ./configure --with-fhs --prefix=/usr --sysconfdir=/etc
--sharedstatedir=/var --datadir=/usr/share --with-configdir=/etc/samba
/home/fcmario/tmp/rpm-tmp.457: line 29: ./configure: No such file or
error: Bad exit status from /home/fcmario/tmp/rpm-tmp.457 (%build)

RPM build errors:
    Bad exit status from /home/fcmario/tmp/rpm-tmp.457 (%build)

I've tried to un-tar the source file and changed the lsb-samba.spec in
packaging/LSB directory, tar-ed it again and run rpmbuild -ta
samba-3.0.32.tar.gz but still it came out with the same error messages. Is
anybody here knows how to face this thing, since I've never done this before
and have been struggled for two days just to get an RPM package for my
distro (it's hard to find RHEL 4 rpm for samba-3.0.32 out there - I've
checked dag.wieers and rpmfind). I really apreciate your help. Thank you.


More information about the samba mailing list