[Samba] Common MS Office and samba file share issue

Kevin Bedford kevin at sepit.com.au
Wed Jul 9 00:49:31 GMT 2008

John Drescher wrote:
> On Tue, Jul 8, 2008 at 8:14 PM, Kevin Bedford <kevin at sepit.com.au> wrote:
>> Hi all,
>> There are many posts on many lists about this issue but no definitive
>> answers.
>> For me the issue came up with a new server running CentOS 5 + samba 3.0.35c
>> + openldap.
>> The recent postings I've seen always seem to have either RHEL 5 or CentOS 5
>> in common with the provided 2.6.18 kernel.
>> The issue is .doc or .xls files saving and then producing an error about not
>> being able to open the file for writing.  Then it claims the file is locked
>> by the user who just saved the file.  It even occurs in users own home
>> directories where no one else could have opened the file
>> I've tried disabling kernel locks, oplocks, level2 oplocks, create mode
>> =0660 and
>> SO_SNDBUF=8192
> Disable any socket options on 2.6 kernels as the os handles this better.
>> All of which have been listed somewhere as fixes but do not help.  I've been
>> searching for a solution for nearly two months now.
>> Can someone please tell me what it is????
> The problem is instead of saving a file excel and word create new
> files with a temp name then delete the old file then rename the new
> file to the same name as the old. When this rename takes place the
> windows filesystems apply the permissions of the old file to the new
> file. The problem is linux filesystems do not do this weird behavior
> so with samba you have to force it using the force create mode param
> and force directory mode param.
> John
Thanks John,

I have those options set on each share as create mode = 0660 and 
directory mode = 0770.  I tried adding 'force' to those lines but the 
problem appeared to get worse.  Is the 'force keyword important or is 
this two ways of saying the same thing and any change was purely 

many thanks


More information about the samba mailing list