[Samba] ldap passwd sync not working

Fabiano Caixeta Duarte fcd.listas at gmail.com
Thu Feb 14 01:25:41 GMT 2008

Jerome Tournier escreveu:
> Le Tue, Feb 12, 2008 at 09:44:01AM -0200, Fabiano Caixeta Duarte a ecrit:
>> Hi, there!
>> When my XP users try to change passwords, they get a message saying that
>> password has been changed. That's not true!
> I can confirmed you that the following configuration work for me:
> unix password sync = No
> ldap passwd sync = Yes
> passwd program = /usr/sbin/smbldap-passwd -u %u
> passwd chat = "Changing password for*\nNew password*" %n\n "*Retype new password*" %n\n"

I assume that your ldap sync passwd is enough (like I wanted to) because 
smb.conf tells us that passwd chat is not used if unix password sync is 
set to no.

passwd chat (G)
     Note that this parameter only is only used if the unix password 
sync parameter is set to yes.

So, as I told Edmundo in my last post, I tried using

unix passord sync = yes
passwd program = /usr/local/sbin/smbldap-passwd -u %u
passwd chat = "Changing UNIX password for %u"*New*password:* %n\n 
"*Retype new password:*" %n\n

and it sort of worked. Both samba and unix passwords were changed, but 
users get a message telling they don't have permission to change 
passwords. In addition, it takes too long since user try the operation 
until system respond.

Could you post (or send me in PVT) your smb.conf. I think this will help 
a lot. Please inform either the version of OS, samba and openldap.

I'm using FreeBSD 6.3 in both samba and openldap servers, Samba 3.0.26a 
and openldap 2.3.38. Not using PAM.

Fabiano Caixeta Duarte
Especialista em Redes de Computadores
Linux User #195299
Ribeirão Preto - SP

More information about the samba mailing list