[Samba] Re: winbindd_privileged problem with 3.0.28a

Dave Randolph drandolph at nstarbank.com
Wed Apr 30 15:43:03 GMT 2008

Dave Randolph <drandolph <at> nstarbank.com> writes:

> Hi, all.
> Has anyone else experienced issues with using ntlm_auth in 3.0.28a?  We have 
> had squid set up to use ntlm_auth for quite some time & the latest update 
> seems to break.  

Just to give an update on this.

The problem seems to be related to the nesting of group membership.  If I run 
squid with an effective group of "wbpriv" it works fine.  If I simply add 
squid to the wbpriv group & run it with effective group of "squid" I get 
the "winbind_crap" error.  

Like I said in the original , this was working fine with squid as a member of 
the wbpriv group in a previous build (honestely can't remember what I was at 
before this one but I'm using Fedora core 8).

Before I make my next statement I would like to say that I haven't looked at 
the code so I can't speak with any authority.  
That said, this may be a kernel or other kind of issue (We are at
42.fc8 if it helps anyone out.) I tried an experiment by loading up a 3.25.x 
build & I now have the same behavior.  
I will keep researching & see if I can find an answer to this.  If anyone can 
shed any light on what is going on I would really appreciate it.

More information about the samba mailing list