[Samba] Samba can't find its hostname via broadcast

Atrox silver.salonen at gmail.com
Thu Oct 18 05:44:33 GMT 2007

Michael Lueck wrote:
> Atrox wrote:
>> Samba can't find its hostname via nmblookup:
>> $ nmblookup -B frontier
>> querying frontier on
>> name_query failed to find name frontier
> Have you ever had another (multiple) IP addresses on this particular
> installation? Long long ago I ran into issues with a test box that had
> been known by several IP addresses over the course of time. 
> nmbd got confused and did not know the IP address of the server itself.
> I flushed the wins cache on the PDC and all was well. That is...
> stopped samba
> deleted /var/run/samba/wins.tdb
> started samba
> In my case, it tried the oldest two IP addresses the server had been known
> as, just not the current IP address. Flushing WINS resulted in WINS being
> rediscovered, and thus the current IP address of 
> the server was detected, and "samba could find itself again!"

Hmm, actually the machine runs OpenVPN too, so its (bridged) tap device has
its own IP that falls into the same netmask /24. Is it possible that Samba
may get confused about that? Should specifying only the internal interface
(and lo0 maybe) in "interfaces" help in this case?

PS. I can't try deleting the wins cache right now as Samba is in active use.
View this message in context: http://www.nabble.com/Samba-can%27t-find-its-hostname-via-broadcast-tf4633404.html#a13268471
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list