[Samba] username with @ (at character) - problems with authentication (CUPS)

Piotr Kierklo piotr.kierklo at worlditsystems.com
Tue Oct 16 13:57:49 GMT 2007

Hi all

I tried to set up a printer, which I need to acces using my username.
Unfortunatelly, username contains @ (at) inside. I tried different form 
of escaping (using backslash, unicode value, quotes etc).
Nothing works.

my username is:  abc at domain.com
my password is:  12345678
printer server is:  srv-file
printer name (with space):  KyC2520 WITS

 From various docs i found the URI form I need, to configure the printer


So I did:

#lpadmin -p kyo -P /tmp/PPD/English/Kyocera_KM-C2520_en.ppd \
-v smb://"abc@domain.com":12345678@srv-file/"KyC2520 WITS" \
-D kyo -o printer-is-shared=false

But the CUPS display this URI as (it ignores the first @ character):

   smb://domain.com:12345678@srv-file/KyC2520 WITS

Printer is accessible from Windows, I want to make it working with my 
Linux box.

Can someone instruct me how to pass the @ character in username string?


       ---   Piotr Kierklo   ---
  Systems Engineer at World IT Systems
-- piotr.kierklo at worlditsystems.com --

More information about the samba mailing list