[Samba] Cannot join domain

Beginner dermot at sciencephoto.co.uk
Mon May 21 08:53:08 GMT 2007


Samba V 3.0.25 on Red Hat Enterprise Linux  5
PDC: NT 4 Domain.
Server security = domain.

I have a server (possibly 2) that cannot join the domain. I have 
tried from the linux server with 'net rpc join' and from the NT Box's 

Server Manager but it fails. The server appears in Server Manager 
although you can not get any additional info about it.

The NT BOX's event viewer has an error the error:
"The session set-up computer SERVER failed because there is no trust 
account in the security database for this computer. The name of the 
account references is SERVER$"

There are a few errors in the PDC's log file:
Remote machine MYPDC pipe \NETLOGON fnum 0x480d bind request returned 


[2007/05/21 10:08:25] 
  get_schannel_session_key: could not fetch trust account password 
for domain 'MYDOMAIN'

[2007/05/21 10:08:25] 
  cli_rpc_pipe_open_schannel: failed to get schannel session key from 

server MYPDC for domain MYDOMAIN.

I have tried a number of things, disabling firewall, changing netbios 

name, deleting the server from Server Manager and upgrading to the 
latest release but I the error persists.

Can anyone offer any advice?

More information about the samba mailing list