[Samba] Joining an 2003 AD

Don Meyer dlmeyer at uiuc.edu
Tue May 1 03:55:56 GMT 2007

No, on systems that I have attempted to override this error and join 
the domain with the system's given name, I have been unable to do so 
with the Domain Admin credentials that the error states is required 
for success.

My current domain join workaround for a rebuild/new system is to 
install the 3.0.23-6 packages,  run the 'net ads join', then 
immediately update to current version.


At 10:31 PM 4/30/2007, Kemp, Levi wrote:
>  Don, are you saying that despite putting in both you still get this error?
>At 04:39 PM 4/30/2007, Aaron Kincer wrote:
> >You must make sure that the hostname set in /etc/hostname and what
> >you have for your server string are exactly the same. At least
> >that's how I fixed it. On Edgy 6.10/Samba 3.0.22, I didn't have to do this.
>The gotcha is that I get this failure despite attempting the 'net ads
>join' with Domain Admin credentials...    (Even up through 3.0.25rc3)

Don Meyer                                           <dlmeyer at uiuc.edu>
Network Manager, ACES Academic Computing Facility
Technical System Manager, ACES TeleNet System
UIUC College of ACES, Information Technology and Communication Services

   "They that can give up essential liberty to obtain a little 
temporary safety,
         deserve neither liberty or safety."     -- Benjamin Franklin, 1759 

More information about the samba mailing list