[Samba] Windows won't recognize hostname of server

Don.Walters at FalconJet.com Don.Walters at FalconJet.com
Wed Mar 21 14:04:19 GMT 2007

> Last time you posted your smb.conf it included the line
> wins server = <censored>
> So, not knowing the ip address of your WINS server I suggested you try
> nmblookup -R -U ipaddr.of.wins.server mis001
> I thought you'd realize for ipaddr.of.wins.server you where supposed
> type in the ip address of your WINS server.
> Today when you posted your smb.conf you've got the line
> wins server =
> What happens when you issue the following command?
> nmblookup -R -U mis001

I'm really sorry.  That was quite a foolish mistake on my part.  Clearly
I have too much to do... so much that I'm not investing enough thought
in what I'm doing anymore.

I tried running the command from various machines but I always get the
same answer...

name_query failed to find name mis001

I also have found out there is another samba server on our network.
Running the same command with its hostname instead of mine renders the
same result.  That server is version 2.2.12 running on AIX 5.

Here is the config on that machine...

        workgroup = DFJ
        netbios name = DFJ250
        server string = Samba srvdfj250
        security = SERVER
        encrypt passwords = Yes
        password server = lr-dc01
        username map = /usr/local/samba/lib/username.map
        log file = /local/samba/var/log.%U
        max log size = 50
        name resolve order = wins bcast host
        load printers = No
        character set = ISO8859-1
        wins server =
        create mask = 0777
        directory mask = 0777
        follow symlinks = No

I have looked closely at its config file and even tried using elements
from it in my own config file, but its not helping.  If anyone has any
suggestions of what I may want to try, I'd be happy to hear them.  But
the conclusion I am reaching is that I need to install another version
of Samba and maybe this will resolve itself.

One final thing...  I was looking at my log files and I noticed that
clients on the same subnet as my server are being logged as their
hostname, while clients connecting from different subnets are logged as
their IP address.  I don't know if this because name resolution isn't
working too well, or if this is normal behavior.

More information about the samba mailing list