[Samba] /etc/fstab and windows share problem

Dariusz Trzaska sanefirst at gmail.com
Tue Mar 6 22:20:57 GMT 2007

I`ve got a problem with samba and /etc/fstab.
I have a second computer running Windows XP SP2 with Western Digital 
MyBook USB2 external hard disk attached. The Disk is shared over windows 
network with a label "My Book (J)".
I can manually mount this samba resource by typing "sudo mount -t smbfs 
-o fmask=777,dmask=777,guest '//win/My Book (J)' /media/MyBook", but I 
can't figure out how to mount it by using fstab...
The problem is with the disk label, as it contains three strings: "My", 
"Book" and "(J)".

I tried:
//win/My Book (J) /media/MyBook smbfs guest,dmask=777,fmask=777 0 0
'//win/My Book (J)' /media/MyBook smbfs guest,dmask=777,fmask=777 0 0

I also tried replacing ' with " but nothing has changed.

PS. Windows doesn't allow me to share the disk with one-word label... 
the ... (J) is always there.

Plz someone help me,

More information about the samba mailing list