[Samba] Trouble adding samba server to a domain

Roman Bigler roeme at roeme.ch
Mon Mar 5 21:52:42 GMT 2007

Ooops, forgot to CC the list.

Begin forwarded message:

> From: Roman Bigler <roeme at roeme.ch>
> Date: March 5, 2007 22:51:53 GMT+01:00
> To: <Don.Walters at FalconJet.com> <Don.Walters at FalconJet.com>
> Subject: Re: [Samba] Trouble adding samba server to a domain
> Hi,
> the topic of your message differs from the content. Do you have a  
> domain in use?
> Were you able to sucessfully add the machine to the domain with  
> kerberos?
> What are your requirements for this server anyway?
> On Mar. 5, 2007, at 22:06 , <Don.Walters at FalconJet.com>  
> <Don.Walters at FalconJet.com> wrote:
>> I'm trying to add a samba server to our company network.  The  
>> samba version is 3.0.10 running on Fedora Core 1.
>> The problem I'm having is the Windows PCs (XP and 2000) that are  
>> trying to connect to the server won't recognize the hostname of  
>> the server - only the IP address.  For example, putting in \ 
>> \192.zzz.yyy.xxx will display the shares just fine, but putting in  
>> the hostname \\mis001 will not.  The error says that "The account  
>> is not authorized to login from this station".
>> I started Googling for the answer, and I discovered the typical  
>> solution involves the use of encrypted passwords.  I have  
>> completely exhausted this solution to no avail.  I have tried  
>> adding the declaration "encrypt passwords = yes" and I have tried  
>> enabling and disabling the windows registry settings to allow or  
>> disallow the use of encrypted passwords.  This doesn't seem to be  
>> the answer.
>> When I go to the Windows command prompt and type... "net use \ 
>> \mis001 /user:myuserid" the prompt tells me "the command completed  
>> successfully".  Once I do that and go to My Computer and put in  
>> the hostname \\mis001 it displays my shares!  It seems this  
>> command is all I need to make it work, but I don't want to make a  
>> login script for every Windows box that needs to connect to this  
>> server.
>> Here's my config file.  Some of the commands I'm using here may  
>> look a little wonky but this is the current state of my config.   
>> I've been changing and changing different commands for days now  
>> trying to make it work, so there were a few times where I got  
>> desperate and tried using commands that may not belong together.   
>> Also note that I'm censoring some of the values. I hate doing that  
>> since it limits everyone's ability to help me, but since this is a  
>> company server, I don't want to get in trouble for posting this  
>> stuff.  I also have not shown the individual shares I'm exporting,  
>> but it shouldn't make any difference because the root of my  
>> problem is in the global settings, I believe.
>> [global]
>>         workgroup = OURCO
>>         netbios name = mis001
>>         server string = MIS Support Server
>>         security = SHARE
>>         password server = <censored> # Don't even know if I need  
>> this, considering its security = share
>>         log file = /var/log/samba/log.%m
>>         read raw = No
>>         name resolve order = wins host bcast
>>         socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192  
>>         load printers = No
>>         lm announce = Yes
>>         wins server = <censored>
>>         kernel oplocks = No
>>         ldap ssl = no # I am using ldap for dns resolution so I  
>> figured this may help
>>         preload = Yes
>>         force user = <censored>
>>         force group = <censored>
>>         guest ok = Yes
>>         null passwords = yes
>> I should also mention that I've been over and over this in regards  
>> to my DNS.  I have added the machine to LDAP.  I can ping the  
>> machine's hostname from other hosts.  I can also put http://mis001  
>> in the browser and I can view the web server that's running there  
>> too.  I feel pretty sure the DNS is setup correctly but I'm not  
>> above the possibility that something could be wrong.
>> Strangely, I have one user (on a Windows client) who has no  
>> trouble connecting to the share using the hostname (i.e. \ 
>> \mis001).  This is completely bizarre because he and I are both on  
>> the same subnet as the samba server and I am unable to connect  
>> unless I run the DOS command...
>> net use \\mis001 /user:myuserid
>> After which I am able to connect to the share just fine using the  
>> hostname.
>> When I don't include my userid in this command, I get the error  
>> message...
>> System Error 1240 has occurred
>> The account is not authorized to login from this station.
>> I would appreciate any help you all can provide.
>> Thank you all in advance.
>> --
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/listinfo/samba

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url : http://lists.samba.org/archive/samba/attachments/20070305/890a736f/PGP.bin

More information about the samba mailing list