[Samba] Help with smbmount

James Watkins misterwatto at gmail.com
Fri Jun 29 11:30:21 GMT 2007

On Thursday 28 June 2007 20:33, Felipe Augusto van de Wiel wrote:
> On 06/22/2007 01:46 PM, Barry Stear wrote:
> > I am trying to mount another linux samba mount on my
> > linux machine. I can only mount using root account and
> > when i do this the permissions for the samba mount are
> > all owned by group root and user root. I want to have
> > rw access to this by myself. I have even specified in
> > the options of smbmount a uid and gid but still no
> > luck.
> 	Have you tried LinNighborhood?
> 	Mount a CIFS/SMB filesystem is not much different from
> a regular block device, the restrictions and security limitations
> still applies, you can add a line to /etc/fstab to allow users to
> mount it and specify the options.
> 	You can also use SUID approach or have it automounted on
> boot or other software. And using uid,gid is supposed to work.
> Can you show the command lines, permissions and errors? (Logs?)

I was recently caught out by the unix extensions that samba supports.  It 
turns out that if the server supports unix extensions then smbmount will 
apply the permissions as they are on the server and ignore the uid and gid 
options.  I dare say there may be a way to disable this at the smbmount end 
of things but I didn't have the time to find out so I just disabled unix 
extensions on the server.  If you find out how to do it at the client end I 
would be interested to know.



More information about the samba mailing list