[Samba] Connection problem with 3.0.25a

Torsten tkali at bredex.de
Mon Jun 25 09:30:25 GMT 2007

Hi Darin.

Are you aware of the follwoing (taken from the release-notes for 3.0.25):

Changes to MS-DFS Root Share Behavior
Please be aware that the initial value for the "msdfs root" share
parameter was changed in the 3.0.25 release series and that this
option is now disabled by default.  Windows clients frequently require
a reboot in order to clear any cached information about MS-DFS
root shares on a server and you may experience failures accessing
file services on Samba 3.0.25 servers until the client reboot
is performed.  Alternately, you may explicitly re-enable the
parameter in smb.conf.   Please refer to the smb.conf(5) man page
for more details.

Maybe you can try an switch-on dfs again, to see if it works.

-- Torsten.

Darin wrote:
> Hello all,
>   I've tried everything I can think of, I've gone through Google and 
> the Samba website and I can't come up with a fix for this problem.
> I've been running Samba 3 for at least the past year with no 
> problems.  I run a small FreeBSD 6.2 box that I use as a storage area 
> for the windows XP systems on my network.  Things have been fine up 
> until 3.0.25 and 3.0.25a.
> Now, when I try to connect to one of the shares, I get the following 
> from windows:  "Y:\ refers to a location that is unavailable.  It 
> could be on a hard drive on this computer or on a network. Check to 
> make sure that the disk is properly inserted, or that you are 
> connected to the internet or your network, and then try again.  If it 
> still cannot be located, the information might have been moved to a 
> different location."
> I also get that error if I browse to the share on the network and try 
> to connect that way, instead of using the mapped drive letter.
> I've tried completely uninstalling 3.0.25a, removing all TDB files, 
> everything and then recompile and reinstall fresh.  Any time a machine 
> on the network tries to connect, the following is logged in 
> /var/log/samba/log.
> [2007/06/23 03:07:24, 1] smbd/service.c:make_connection_snum(1033)
> ( connect to service backup$ initially as 
> user nobody (uid=65534, gid=65534) (pid 63261)
> [2007/06/23 03:07:34, 1] smbd/service.c:close_cnum(1230)
> ( closed connection to service backup$
> I'm using share level security.  I have the share set to be accessible 
> by anyone on the network so that any machine has full write access.
> If I remove 3.0.25a and fall back to 3.0.24, everything is fine.  I 
> don't make any changes to the smb.conf file.  It just starts working 
> when I go back to 3.0.24
> Here is my smb.conf:
> [global]
>   workgroup = MYNET
>   server string = Backup Server
>   security = share
>   hosts allow = 192.168.0. 127.
>   log file = /var/log/samba/log.%m
>   max log size = 5000
>   interfaces = txp0
>   dns proxy = no
> [backup$]
>   comment = backups
>   path = /archive
>   browseable = yes
>   only guest = yes
>   public = yes
>   guest ok = yes
>   writeable = yes
> Any help would be greatly appreciated.
> Thanks
> Darin -

More information about the samba mailing list