[Samba] [3.0.23d] Subdirectories of share root appear empty (sometimes)

Jeremy Allison jra at samba.org
Mon Jun 18 23:15:02 GMT 2007

On Mon, Jun 18, 2007 at 02:59:56PM +0100, James Farmer wrote:
> Hi.  We're having a bit of a strange problem with Samba, and we're
> hoping someone might be able to offer some good advice as it's
> exhausted our ideas.  Thanks.
> Our office has a SUSE Linux box that we use as a fileserver, using Samba
> to expose it to our Windows machines, in the form of three shares.
> Sometimes (it's inconsistent but seems to happen several times a week),
> one of our computers will stop 'seeing' the contents of the
> subdirectories of the root of one of the shares.  When we open the
> share in Explorer, the contents of the root appears as expected, but
> when we navigate into any subdirectory it appears as empty.  Meanwhile,
> we can open the share on another machine, and all the subdirectory
> contents appear as expected.
> We've observed this problem on one (and only one) of the shares, which
> is itself confusing as they're all configured exactly the same.  We've
> tried rebooting the Windows machine but the same problem is observed
> when it comes back.  We've also tried rebooting the Samba service, but
> again the same problem is observed!  If we leave it for long enough,
> however, eventually it starts working again.  Our best guess is that
> the Windows machine somehow caches some bad data, somehow.
> Thus far this problem has only been observed from two of our Windows
> machines; one runs 32-bit Windows XP Pro and the other 64-bit Windows
> Server 2003.
> The Samba log shows everything appearing normal, e.g.:
> [2007/06/18 14:07:12, 2] auth/auth.c:check_ntlm_password(309)
>   check_ntlm_password:  authentication for user [fred] -> [fred] -> 
> fred] succeeded
> [2007/06/18 14:07:12, 2] lib/access.c:check_access(323)
>   Allowed connection from  (
> [2007/06/18 14:07:12, 1] smbd/service.c:make_connection_snum(950)
>   kronos ( connect to service CVS initially as user fred 
> (uid=1000, gid=100) (pid 18524)
> [2007/06/18 14:07:12, 2] smbd/reply.c:reply_tcon_and_X(711)
>   Serving CVS as a Dfs root

I don't suppose you could try 3.0.25 could you ? I re-wrote most
of the DFS code for this release - and this type of thing definately
sounds like a DFS bug.


More information about the samba mailing list