[Samba] Invalid Argument ls dir mounted share

Max Kipness max at assuredata.com
Tue Jun 12 12:45:03 GMT 2007

I'm using Fedora Core 6 which uses cifs.mount version 1.10. When mounting
shares from a particular Windows 2003 R2 server, I cannot read certain
directories. For example, when performing an 'ls' command as follows:

[root at backup Admin]# ls /share/CORP-SERVER/C\$/Corp/User\ Files/xxx\
Finacial\ Shared/Admin/Freddie\ Mac/
ls: reading directory /share/CORP-SERVER/C$/Corp/User Files/xxx Finacial
Shared/Admin/Freddie Mac/: Invalid argument

No matter how I try to read this directory 'Freddie Mac' I get the same
error. I can even CD into the directory, but when doing an 'ls' from inside,
I get the same error.

The mount with cifs succeeds fine, no errors. 98% of the directories can be
read fine, but there are a few that give this error.

After some testing it seems like the problem has to do possibly with the
type of files, or characters in the name. In this directory there are many
.docx files. Also some of the files names have pound signs and some file
names start with a number. The strange thing is that if I move all files
except for 47 of the files, I can do the 'ls' from linux. However, if I add
the 48th file back to this directory I start getting the 'Invalid Argument'
error again. I tested other directories with more than 48 files and never
get this error, so it has something to do with these files and having more
than 48. I also moved the files to a different folder, and still had the
same error reading the new folder contents.

Anybody have any clue as to what the problem might be? Any tips on what I
can try to remedy? Anything?


View this message in context: http://www.nabble.com/Invalid-Argument-ls-dir-mounted-share-tf3907351.html#a11078126
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list