[Samba] Rpcclient adddriver Samba 3.0.25

Gerald (Jerry) Carter jerry at samba.org
Mon Jun 4 16:18:39 GMT 2007

Hash: SHA1

Hey Mark, :)

> I'm trying to use rpcclient to add a driver to a Samba 3.0.25 
> running on  Gentoo.  When I run the script below, rpcclient prints
> out the same message  as if "--help" was submitted as the
> only switch.
> #!/bin/bash -x 
> RPC="/usr/local/samba/bin/rpcclient"
> ARCH='Windows NT R4000' 
> #ARCH='Windows NT x86'
> DRIVER='HP LaserJet 4Si/4Si MX  
> PS:pscript.dll:hp4si_v4.ppd:pscriptui.dll:pscript.hlp:NULL:raw:NULL' 
> SYSTEM=scooby
> $RPC -U markg -c adddriver "$ARCH" "$DRIVER" $SYSTEM 
> The correct files are copied to: /var/lib/samba/printers/W32MIPS.  
> And there is a directory named "2" under the W32MIPS directory.
> I've also tried adding it from the rpcclient prompt, which 
> produced the following error message:  WERR_UNKNOWN_PRINTER_DRIVER
> Any suggestions as to how I can accomplish adding this 
> driver would be greatly  appreciated.

I don't think driver uploads have ever been tested with
anything but Intel drivers.  We relaxed the arch checks
when reading the PE_HEADER on the driver config file in 3.0.25.
If you have not testing against 3.0.25a, you might want to
see if that helps.

cheers, jerry
Samba                                    ------- http://www.samba.org
Centeris                         -----------  http://www.centeris.com
"What man is a man who does not make the world better?"      --Balian
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the samba mailing list