[Samba] Rpcclient adddriver Samba 3.0.25

Mark Gannon mark at truenorth.nu
Mon Jun 4 15:23:32 GMT 2007


I'm trying to use rpcclient to add a driver to a Samba 3.0.25 running on 
Gentoo.  When I run the script below, rpcclient prints out the same message 
as if "--help" was submitted as the only switch.

#!/bin/bash -x 


ARCH='Windows NT R4000' 
#ARCH='Windows NT x86'
DRIVER='HP LaserJet 4Si/4Si MX  

$RPC -U markg -c adddriver "$ARCH" "$DRIVER" $SYSTEM 

The correct files are copied to: /var/lib/samba/printers/W32MIPS.  And there 
is a directory named "2" under the W32MIPS directory.   

I've also tried adding it from the rpcclient prompt, which produced the 
following error message:  WERR_UNKNOWN_PRINTER_DRIVER

Any suggestions as to how I can accomplish adding this driver would be greatly 


Mark Gannon

"Sometimes I wonder whether the world is being run 
by smart people who are putting us on, 
or by imbeciles who really mean it."

- Mark Twain
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20070604/aec42215/attachment.bin

More information about the samba mailing list