[Samba] Re: Repost: Can't follow DFS link

Kent Tong kent at cpttm.org.mo
Mon Jun 4 06:53:04 GMT 2007

Jim McDonough <jmcd <at> samba.org> writes:

> On 6/1/07, Kent Tong <kent <at> cpttm.org.mo> wrote:
> >   smb_flg2=51203
> >
> Kent, I know you already rebooted the client since we discussed this before
> (though did you reboot the terminal server?).  This flags2 value is 0xC803,
> and we need to see the 0x1000 bit on before we recognize that the client is
> interested in DFS pathnames.  So now comes the tricky part...why is this
> client different from your other client that works? 

I've tried it on three clients: two Win2K pro and one Win2K terminal server.
Only one Win2K pro works. All have been rebooted.

> Can you give me
> anything on how you connected, security environment (ADS vs USER vs DOMAIN),
> or even how you specified the server address (netbios name, dns name, ip
> address)?  These can all play a role, unfortunately, in how a window client
> decides to ask for DFS referrals.

We're in a Win2K AD domain. The DFS host (samba) is using user security
and have the user accounts in the samba password DB (yes, we duplicated
the user accounts from AD and it works fine). The share is access using
netbios name. I just tried accessing it using IP and it works! What can
I do in that case?

More information about the samba mailing list