[Samba] users via winbind and using @group in smb.conf

Michael Gasch gasch at eva.mpg.de
Fri Jan 5 11:25:35 GMT 2007

could you please try the latest samba (or at least 3.0.23c) and use

valid users = "Unix Group"\your_local_group



Stefan Froehlich wrote:
> On Thu, Jan 04, 2007 at 02:35:30PM +0100, Voelz Alexander wrote:
>>>> [...] what das NOT work is to assign a samba share on B to this
>>>> local group. I tried
>>>> | valid users = @group
>>>> as well as
>>>> | valid users = @DOMAIN\group
>>>> but both ways all I get is NT_STATUS_ACCESS_DENIED.
>> Does wbinfo work?
>> e.g. does wbinfo -g list the private group?
> No, it does not - but should/must this be the case? AFAIK wbinfo only
> lists group, which are known in the DOMAIN context. However, @private
> is a local unix group which is only relevant to the samba process on
> server B. If I use any other local group (without users imported via
> winbind) they are not listed by "wbinfo -g" as well, but still they
> behave like expected.
>> Did you try "valid users = DOMAIN\private"?
> I tried "valid users = @DOMAIN\private", (with the @ to indicate a
> group) but it did not work either - which I expected because it is
> not a group defined in the DOMAIN context.
> Bye,
>   Stefan

More information about the samba mailing list