[Samba] FreeBSD and Winbind

Don McCall donmccall1 at yahoo.com
Sat Feb 10 03:10:36 GMT 2007

Ok, Jay,
This is a real long shot, but I did run into a similar problem on SLE9 Suse Linux system.  Same sort of symptoms, wbinfo would work but getent, etc would not.  
Finally determined that  the ncsd service was interfering with the operation of winbind - so
  it had to be turned off:

      /etc/rc.d/nscd stop
      chkconfig nscd off

After that, it all worked.  
I'm not familar with FreeBSD, don't even know if there IS an nscd service on it, but it's the last thing I can think of.

----- Original Message ----
From: "jhall at vandaliamo.net" <jhall at vandaliamo.net>
To: don at videon-central.com
Cc: samba at lists.samba.org
Sent: Friday, February 9, 2007 8:36:07 PM
Subject: RE: [Samba] FreeBSD and Winbind

Thanks to everyone for the help.  I still cannot get getent passwd or
getent group to work.  This is what I have done since last round of
e-mails.  If anyone sees anything glaringly obvious, please let me know.

1.  Compiled samba from source with --prefix=/usr/local/samba
--with-smbtar --with winbind.

2.  Modified /etc/nsswitch.conf with
     passwd: files winbind
     group: files winbind

3.  Copied nss_winbind.so to /usr/lib/libnss_winbind.so and created a
symbolic link to the file for libnss_winbind.so.2.  libnss_winbind.so has
permissions of 444 and is owned by root:wheel.

4.  Copied nss_wins.so to /usr/lib/libnss_winbind.so and created a
symbolic link to the file for libnss_wins.so.2.  libness_wins.so has
permissions of 444 and is owned by root:wheel.

5.  Ran ldconfig -r to reload shared objects.  libnss_winbind and
libnss_wins are listed.

6.  Started winbind.  No errors.

7. wbinfo -u and wbinfo -g return the user and group names.

8.  getent passwd and getent group only return local groups and users.

If anyone sees anything obviously wrong, please let me know.



> Hi Jay,
>   I just went through something similar on the list.  If you are able to
> use
> wbinfo -u to see the users, but cannot see them with getent, the issue is
> almost certainly with the libnss_winbind.so library or in your
> nsswitch.conf
> configuration.
>   I believe where the libraries need to be located depends on your linux
> flavor.  I can tell you that on Gentoo with 3.024, they are the following:
> /usr/lib/libnss_winbind.so
> /usr/lib/libnss_winbind.so.2 -> libnss_winbind.so
> /usr/lib/libnss_wins.so
> /usr/lib/libnss_wins.so.2 -> libnss_wins.so
>   I believe I have seen documentation which locates them in lib/security
> for
> Solaris, and I have seen them as both nss_ and libnss_ in various
> documentation and posts, so you should check the install documentation for
> FreeBSD.
>   The nsswitch.conf check is quite simple - you need to make sure winbind
> is
> listed as an information source.  My nsswitch.conf on gentoo needed to
> have
> winbind added on the following:
>   passwd: files winbind
>   group: files winbind
>   Depending on what you have installed, you may need compat, db, nis, or
> other information stores listed at appropriate places in nsswitch.conf or
> the FreeBSD equivalent.  Since I don't run FreeBSD, I don't want to steer
> you too far off track.
>   Sincerely,
>     Donald
> -----Original Message-----
> From: samba-bounces+don=videon-central.com at lists.samba.org
> [mailto:samba-bounces+don=videon-central.com at lists.samba.org] On Behalf Of
> jhall at vandaliamo.net
> Sent: Wednesday, February 07, 2007 7:15 PM
> To: samba at lists.samba.org
> Subject: [Samba] FreeBSD and Winbind
> I'm hoping this is an easy question, but the way my day has gone I
> seriously doubt it is going to be.
> Today, I installed Samba 3.0.24 with winbind support on my FreeBSD 6.2
> server.  I am able to join my domain and get information concerning groups
> and passwords from the domain controller (Windows 2003) without any
> problem.
> Where I have run into a problem is using getent to get a copy of the
> usernames/passwords and groups moved to the Samba machine.  When I run
> getent, only information from the local passwd and group files is
> displayed.  Which leads me to believe this is an nsswitch problem.
> To be more specific I think I have made a mistake copying the libraries to
> the proper location.  I was not able to find libnss_winbind.so in
> /usr/samba/source/nsswitch.  Instead, I found nss_winbind.so.  Is this the
> correct file to copy?  And, where should these files be copied to on
> FreeBSD?  From what I have read so far, I am guessing these should be
> copied to /usr/lib.
> I have run ldconfig and it shows (using -r) libnss_winbind.so.1 and
> libnss_winbind.so.2 being listed in the hints file.
> My nsswitch has the following configuration
> passwd: files winbind
> group: files winbind
> group_compat: nis
> hosts: files dns
> networks: files
> passwd_compat: nis
> shells: files
> Any suggestions concerning how to proceed would be greatly appreciated.
> Thanks,
> Jay
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba

Do you Yahoo!?
Everyone is raving about the all-new Yahoo! Mail beta.

More information about the samba mailing list