[Samba] RH Enterprise Question

Dale Schroeder dale at BriannasSaladDressing.com
Fri Feb 9 14:22:35 GMT 2007


These are the options that I explicitly set to make Samba/CUPS printing 
work for me.  Note: These may or may not be what _you_ want.

load printers = Yes
show add printer wizard = Yes
printing = cups
printcap name = cups
use client driver = No

comment = All Printers
    path = /your/path
    public = Yes
    guest ok = Yes
    browseable = No
    printable = Yes
    admin users = @"DOMAIN\Domain Admins", DOMAIN\dale
    writeable = No

    comment = Printer Driver Download Area
    path = /your/path
    browseable = Yes
    guest ok = No
    read only = Yes
    write list = @"DOMAIN\Domain Admins", DOMAIN\dale
    admin users = @"DOMAIN\Domain Admins", DOMAIN\dale

As you can see, we are on a domain, and the permissions that I used on 
the directory that contains the print drivers are 775 and owned by 
root:"domain users".
If you are using the postscript drivers in CUPS, have you tried printing 
from within Linux to verify that CUPS is OK?
Since the steps were not intuitive for me, the first time I set this up 
took a lot of trial and error.  I hope this gives a clue as to what 
might work for you.

Good luck,


Danny Ho wrote:
> I modifed the smb.conf
> then kill -1 processid for smb and nmbd
> but is still not showing up my printers in xp.
>     -----Original Message-----
>     *From:* Dale Schroeder [mailto:dale at BriannasSaladDressing.com]
>     *Sent:* Friday, 9 February 2007 3:46 AM
>     *To:* Danny Ho
>     *Subject:* Re: [Samba] RH Enterprise Question
>     Danny,
>     Every configuration that I've seen that uses "printing  =  cups"
>     also sets "printcap name = cups".
>     See if that helps you.
>     Good luck,
>     Dale

More information about the samba mailing list