[Samba] WERR_ACCESS_DENIED trying to set printer driver in samba-3.0.23d

John Drescher drescherjm at gmail.com
Mon Feb 5 22:37:52 GMT 2007

I am having problems getting Pont and Print to work with
samba-3.0.23d, cups and ldap.

I used an XP box to install the windows drivers on the samba server by
adding the drivers in the "Printers and Faxes" section (using the
server properties tab) for the samba server. This part worked fine but
when I want to associate the driver to the printer I get an access
denied in windows and in linux when I try to do the same I get this

fileserver # rpcclient -U RADIMG\\root -c 'setdriver HP-2100 "HP
LaserJet 2100"' FILESERVER  Password:
Connecting to host=FILESERVER
Connecting to at port 445
Doing spnego session setup (blob length=58)
got OID=1 3 6 1 4 1 311 2 2 10
got principal=NONE
Got challenge flags:
Got NTLMSSP neg_flags=0x60890215
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60080215
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60080215
rpc_pipe_bind: Remote machine FILESERVER pipe \lsarpc fnum 0x7352 bind
request returned ok.
lsa_io_sec_qos: length c does not match size 8
rpc_pipe_bind: Remote machine FILESERVER pipe \spoolss fnum 0x7353
bind request returned ok.
SetPrinter call failed!

I have tried several other logins but I can not get by this access denied.

Here are the printer settings from smb.conf

        ldap ssl = false
        host msdfs = no
        lpq cache time = 30
        time server = no
        netbios name = FILESERVER
        printing = cups
        local master = yes
        workgroup = RADIMG
        os level = 33
        ldap admin dn = "cn=Manager,dc=radimg,dc=pitt,dc=edu"
        printcap name = cups
        security = domain
        max log size = 2048
        log level = 3
        log file = /var/log/samba/%m.log
        printer = ar337PCL
        load printers = yes
        ldap user suffix = "ou=People,dc=radimg,dc=pitt,dc=edu"
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        domain master = no
        passdb backend = ldapsam:ldap://sysserv0.radimg.pitt.edu
        keepalive = 0
        ldap delete dn = yes
        server string = File Server
        ldap machine suffix = "ou=Hosts,dc=radimg,dc=pitt,dc=edu"
        ldap group suffix = ou=Groups
        kernel oplocks = no
        ldap suffix = dc=radimg,dc=pitt,dc=edu
        preferred master = no
        domain logons = no
        hide files = desktop.ini
        profile acls = yes

  printable = yes
  path = /var/spool/samba
  guest ok = yes
  comment = All Printers
  create mode = 777
  directory mask = 777
  public = yes
  browsable = yes
#  use client driver = yes
#  enable privileges = yes

   comment = Printer Drivers
   public = yes
   browsable = yes
   path = /usr/share/cups/drivers
   guest ok = yes
   read only = no
   create mask = 777
   directory mask = 777
   write list = root Administrator @"Domain Admins" @"Printer Admins"

John M. Drescher

More information about the samba mailing list