[Samba] samba passwords and ldap + telnet.. SOLVED

L.P.H. van Belle belle at bazuin.nl
Tue Dec 18 08:16:13 GMT 2007


Thanks voor the answheres.

I solved this problem, i use Delta-syncrepl to replicate my databases.
then i us the readonly database. during the database sync something 
went wrong. I resetted my access log of the master database and this solved
my problemen. The exact problem was, that the password fields and the login
wasn't replicated.


>-----Oorspronkelijk bericht-----
>Van: Michael Heydon [mailto:michaelh at jaswin.com.au] 
>Verzonden: dinsdag 18 december 2007 0:10
>Aan: L.P.H. van Belle
>CC: samba at lists.samba.org
>Onderwerp: Re: [Samba] samba passwords and ldap + telnet..
>L.P.H. van Belle wrote:
>> Hi all, 
>> This is maybe not the play to ask, but i'll just ask.
>> I googled a lot but im stuck.. 
>It's not really, this is a pam-ldap issue. The fact that one of the 
>other servers connected to ldap runs samba is inconsequential.
>> Im having samba 3.0.26a on a debian etch server with ldap.
>> Im using a setup like the idealx setup. ( samba pdc + ldap ) 
>> I have replicated my ldap database to a other server. On 
>this server im
>> having
>> a database application running and my users must login 
>> with telnet on this server.
>> Now my problem, Everything works perfectly, exept 1 thing.
>> my samba users are unable to login on server 2 with telnet.
>> I have the pam modules configured, but im still unable to login.
>> I have no errors, execpt 1.
>> this one: 
>> Dec 17 08:52:38 ms249-lin-005 login[1680]: pam_ldap: error 
>trying to bind as
>> user "uid=testuser,ou=Users,dc=locale,dc=domain,dc=internal" (Invalid
>> credentials)
>> Dec 17 08:52:38 ms249-lin-005 login[1680]: (pam_unix) authentication
>> failure; logname= uid=0 euid=0 tty=pts/1 ruser=
>> rhost=PCNAME,locale,domain,internal"  user=testuser
>> Dec 17 08:52:40 ms249-lin-005 login[1680]: FAILED LOGIN (1) 
>on 'pts/1' from
>> PCNAME,locale,domain,internal"' FOR `testuser', 
>Authentication failure
>It would appear that you are trying to bind to the LDAP server as the 
>authenticating user. Does this work? (Try using an ldap client, 
>something like LdapAdmin under Windows, and ensuring that the user can 
>bind and access the relevent data from the directory).
>> i've spent 2 days now and im cant find my problem.
>> I hope someone on this list know the solution.
>> I'm using md5 as encryption in pam-ldap. 
>> I hope someone can help me.
>> Louis
>*Michael Heydon - IT Administrator *
>michaelh at jaswin.com.au <mailto:michaelh at jaswin.com.au>

More information about the samba mailing list