[Samba] test share works, but homes returns with "network name cannot be found

Dan Roberts dan at jlazyh.com
Fri Apr 27 01:17:07 GMT 2007

Just built a new server based on CentOS 5.0 which included Samba 
3.0232.  I also added Webmin as the server is in the closet without a 
monitor currently.

When I went thorugh the generla tutorial with Webmin Samba worked, but 
showed all root directories, except for /home.  That was not as expected 
and certainly not very helpful.

So, I went back and tried again baseed on what I had used in the past on 
the old server. 

I have set up the test share directory and can connect to it without 
problem from either my desktop Win2000 system or my MacBook Pro.  I 
don't have a printer on this server, having switched over to a jetdirect 
card, but I do see the "Printers" icon in the list at least on the Windows.

My home directory is another matter - I can see it and it has the proper 
comment attached, but any attempt to connect from Win2000 results in a 
popup window.  I get rejected from the Mac too, but of course don't get 
the Windows popup window. 

As the Windows popup window actually says something, here it is - top 
line is the banner
\\Trailrunner\dan is not accessable.
The network name cannot be found.
Googeling on this has lead me to various old postings but nothing 
directly on point, and the bid difference I seem to have is that I can 
indeed get to the test share, copy in files etc... without problem.

What follows are the core entries of my smb.conf file, the notations 
from the log file and the results of what seem to be key tests.

Truly hope someone can help me get this sorted out.

#======================= Global Settings 
        log file = /var/log/samba/%m.log
        dns proxy = no
;       passwd chat = *Enter\snew\sUNIX:* %n\n *Retype\spassword:* %n\n
        server string = Trailrunner, Samba %v on (%L)
;       unix password sync = yes
        remote announce =
        workgroup = DJ14847
        os level = 20
        encrypt passwords = Yes
        security = user
;       passwd program = /usr/bin/passwd %u
        max log size = 50
        allow hosts = 10.20.30.
        log level = 3
        socket options = TCP_NODELAY IPTOS_LOWDELAY
        wins support = yes
        netbios name = trailrunner

#============================ Share Definitions 
        comment = %U's Home Directory is %H
        valid users = %S
;       path = %H
        read only = no
        browsable = no
        create mask = 0755
        directory mask = 0755

        comment = for testing purposes only
        path = /export/test
        read only = no
        public = yes


 From the /var/log/samba/ tial superspiff.log file
[root at trailrunner samba]# tail superspiff.log
[2007/04/26 19:11:30, 3] smbd/error.c:error_packet(146)
  error packet at smbd/reply.c(676) cmd=117 (SMBtconX) 
[2007/04/26 19:11:30, 3] smbd/process.c:process_smb(1110)
  Transaction 27 of length 43
[2007/04/26 19:11:30, 3] smbd/process.c:switch_message(914)
  switch message SMBulogoffX (pid 3764) conn 0x0
[2007/04/26 19:11:30, 3] smbd/sec_ctx.c:set_sec_ctx(241)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2007/04/26 19:11:30, 3] smbd/reply.c:reply_ulogoffX(1618)
  ulogoffX vuid=105

Testing locally wiht smbclient
[root at trailrunner samba]# smbclient -L localhost -U%
Domain=[DJ14847] OS=[Unix] Server=[Samba 3.0.23c-2]

        Sharename       Type      Comment
        ---------       ----      -------
        test            Disk      for testing purposes only
        IPC$            IPC       IPC Service (Trailrunner, Samba 
3.0.23c-2 on (trailrunner))
Domain=[DJ14847] OS=[Unix] Server=[Samba 3.0.23c-2]

        Server               Comment
        ---------            -------
        DANS-MAC             Dan's Mac
        TRAILRUNNER          Trailrunner, Samba 3.0.23c-2 on (trailrunner)

        Workgroup            Master
        ---------            -------
        DJ14847              TRAILRUNNER
        KUTAK                DN-ROBERTS-5898
[root at trailrunner samba]#

More information about the samba mailing list