[Samba] Can not grant SeMachineAccountPrivilege on Debian Etch

Michael Lueck mlueck at lueckdatasystems.com
Wed Apr 25 21:15:13 GMT 2007

Dale Schroeder wrote:
> Michael,
> I believe Etch uses Samba 3.0.24. 

Thanks Dale for the quick response.

That is correct, and also the version I have arrived at after several version upgrades. This is the first server I have installed at this level of Samba.

> There were changes in 3.0.23 that 
> require "net groupmap add" rather than "net groupmap modify".
> initGrps.sh will have to be modified accordingly.  See: 
> http://us3.samba.org/samba/docs/man/Samba-HOWTO-Collection/ChangeNotes.html
> I hope that fixes things for you.
> Good luck,
> Dale

1) Running as root, I changed the script from "net groupmap modify" to "net groupmap add".
2) I stopped Samba
3) I deleted the file /var/lib/samba/group_mapping.tdb
4) I started Samba
5) I exited root back to my normal account
6) I ran the command: net rpc rights grant LDS-DEMO\\ldsinst SeMachineAccountPrivilege
and unfortunately it failed with the same error.

"So close..."


Michael Lueck
Lueck Data Systems

More information about the samba mailing list