[Samba] unix password sync = yes, did not sync unix passwd

beast beast at ldap.or.id
Tue Sep 12 06:38:08 GMT 2006

I'm not sure when the last time I run smbpasswd to change the user 
password, however when I run it only change NT and LM hash attribute, 
not the unix passwd attributes.

   passdb backend = ldapsam:"ldap://"
   unix password sync = yes
   passwd program = /usr/local/sbin/passwd.pl %u
   passwd chat = *New*password* %n\n *Retype*new*password* %n\n 

However it was working find (able to change unix as well as NT password) 
when I run from Windows client, such as:
c:\> net user example testonly /domain

This is incorrect, at least per (surprise) pdbedit documentation:

              pdbedit does not call the unix password syncronisation 
script if
              unix password sync has been set. It only updates the data 
in the
              Samba user database.

              If you wish to add a user and synchronise the password 
that  im-
              mediately, use smbpasswd's -a option.

Ver: samba-3.0.20b


More information about the samba mailing list