[Samba] Problem with adding printer drivers in Windows XP

Martin Zielinski mz at seh.de
Thu May 11 06:58:41 GMT 2006

Hi Tom!

You need appropriate rights on the windows- and the unix-side.

To find out, if you're facing a problem with the unix-rights
(which is often the problem), you could try this:

1. Log in directly to the drivers share and
create or delete some files in the W32X86 directory.

On Windows:
start -> execute -> \\nightwolf\print$

On Linux:
smbclient \\\\nightwolf\\print$ -U 'administrator%password'

If this succeeds ... you should be able to add drivers, too.

2. Find out on the samba server which unix-user-id is used by the smbd:

 > smbstatus
Samba version 3.0.20b
PID     Username      Group         Machine
14293   SAVAGEPHP\administrator  SAVAGEPHP\domänen-benutzer  martin 

Service      pid     machine       Connected at
print$       14293   martin        Thu May 11 08:41:56 2006

3. Become this user on the samba server (as root):

 > su SAVAGEPHP\\administrator
 > cd /var/lib/samba/drivers/W32x86
 > mkdir xxx

4. If you have a "unix-rights-problem" this does not succeed.
Check your directory settings (also have a look at the "W32X86/2" and 
"W32X86/3" directory.

Hope that helps

~ Martin

Tom wrote:
> I know this question has been asked quite a few times from the archive, 
> but nothing in the previous posts seems to help my setup. I currently 
> have samba 3.0.21c running on Slackware with CUPS as the printing 
> conduit. It's setup as a PDC as can be seen from the smb.conf file 
> below. I cannot, no matter what I've tried, get the server to allow me 
> to add printer drivers to a printer through the printer properties 
> dialog box. I've given myself the SePrintOperatorPrivilege rights but 
> that didn't work. I tried putting the 'printer admin' directive in the 
> smb.conf file and that didn't work; I know it's deprecated but thought 
> I'd try anyway. Any suggestions would be greatly appreciated as I've 
> been on IRC several times trying to figure this out with no success. 
> I've also tried logging in as 'root' and 'administrator' neither of 
> which work; my /etc/samba/smbusers contains a line: 'root = Administrator'.
> Configuration files are attached. If any other information is needed I 
> will gladly supply it.
> Thank you.
> Tom

Martin Zielinski             mz at seh.de
Software Development
SEH Computertechnik GmbH     www.seh.de

More information about the samba mailing list