[Samba] kinit fails

Gwen Parker gwen.l.parker at duke.edu
Tue May 9 19:54:13 GMT 2006

I'm trying to configure a Solaris 8 system to authenticate Samba against 
Windows 2003 ADS.  I've compiled the appropriate packages; however, I'm 
quickly stuck trying to get my kerberos ticket.   Here's the error:

sumac:/opt/local/kerberos5/bin# ./kinit admin at DCRI.DUKE.NET
kinit(v5): Cannot resolve network address for KDC in requested realm while 

getting initial credentials

Here's the lowdown:
Samba client -- sumac.dcri.duke.edu
ADS server - vmsodium.dcri.duke.net

My /etc/resolv.conf 

sumac:/opt/local/kerberos5/bin# more /etc/resolv.conf
domain dcri.duke.edu

Although I rather not modify my /etc/resolv.conf, I've read that this 
error is due to DNS lookups.  I am able to resolve using nslookup.   I 
have tried 1) adding my ADS server's IP to /etc/resolv.conf and a "search 
dcri.duke.net" line.  I've also tried using the IP in the krb5.conf file. 
I can't get past that error.  Here is my /etc/krb5.conf.. 

        default_realm = dcri.duke.net

        dcri.duke.net = {
#       kdc = vmsodium.dcri.duke.net
        kdc =

        .kerberos.server = dcri.duke.net

Any help would be greatly appreciated. 

More information about the samba mailing list