[Samba] domain controller cannot be contacted

Mark Rutherford mark at maunzelectronics.com
Wed Mar 29 14:44:54 GMT 2006

Hi everyone,

I have struggled with this problem for awhile now. randomly and 
intermittently a workstation or
bunch of workstations will not be able to log in.

This is pretty much reproduceable at will, and here is what you need to 
do to get this little issue to show up:
1. Log out and try to log in as a different user
2. Attempt to login immediately after the machine is booted.

To ensure you can log in, if you boot your workstation in the morning 
and wait 2-3 minutes before trying to log in
you can log in no problem.

I have replaced our switch, cabling, network cards, tried many many 
I took this a step further. I got 3 machines rounded up and built a mini 
network with its own switch.
Only these 3 machines were on this switch.
Of these 3 machines I installed a fresh copy of windows xp with sp2 on 
two of them.
Took our current config and slapped it onto the third machine running 
gentoo + samba

These 3 machines had not been exposed to our main network...
what makes this all so interesting..... I was able to join these 2 
workstations no problem with
default settings, no registry patches, nothing and it just worked.

I tried to reproduce this problem with this little test network and our 
smb.conf for hours on end.
It just never happened.

On our main network I can get this to occur every 2 minutes if I wanted to.
Our samba machine is doing wins as well, and the machines get this wins 
server info with their dhcp info.

Any ideas? Anything at all? This issue is...... just too hard to me to 
figure out.
Also, no indication of an error in any logs.

More information about the samba mailing list