[Samba] fstab based shared user mounts not possible

Martin von Gagern Martin.vGagern at gmx.net
Sat Dec 30 20:01:23 GMT 2006

Don Piven wrote:
> Have you tried "users" instead of "user" in your options list?  Using
> that option allows any user to umount that device.

I just tried that, it allows me to unmount as a common user using the
umount command. One issue solved, thanks for that!

However, it does not help with the fact that the mount point has to be
owned by the user mounting the share. So it's not a complete success, as
the fstab entry is still only usable by exatly one user.

> (And you do realize that /etc/fstab is world-readable, right?)

Sure, but as any user should have access to the share if I got my way,
they might as well know the password as well. The password is there only
for "bad guys" on the LAN, no big secret. And passing that as an option
instead of reading it from the user avoids one possible source of trouble.

 Martin von Gagern

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
Url : http://lists.samba.org/archive/samba/attachments/20061230/6ad7ce09/signature.bin

More information about the samba mailing list