[Samba] Re: core dumps with 3.0.23c SOLVED

Mark Nienberg gmane at tippingmar.com
Wed Dec 27 19:07:37 GMT 2006

Mark Nienberg wrote:
> I have a fedora core 5 server running samba-3.0.23c-1.fc5 from fedora 
> updates.  Recently I changed smb.conf to use security=domain instead of 
> security=user.  The server that it authenticates against is running 
> fedora core 4 with samba-3.0.14a-2.
> Anyway, this setup worked just fine for a couple of weeks, but today I 
> yum updated many packages including pam, glibc and kernel on the fedora 
> 5 server and now, anytime I access a share that includes a setting like
> valid users = @someGroup
> or
> admin users = @someOtherGroup
> I get an smbd core dump.
> If I comment out the line above and restart smb, then all is well.

Restarting the server with the old kernel did not help.
Installing 3.0.23d from the samba.org rpms did not help.

But changing the lines to:
valid users = +someGroup
admin users = +someOtherGroup

fixed it!  I've used the @ sign in smb.conf forever and was unaware of the 
distinction between @, + and &.

I'm not sure what package I updated that changed this from working to crashing, but 
this seems like a little samba bug to me.


More information about the samba mailing list