[Samba] Samba and NFS quota problem

Steve Goodman (lists) steve-lists at aston.ac.uk
Sat Dec 16 19:22:31 GMT 2006


Just in case someone has any idea on how to solve this, I've done some
further testing.

I get the same error below on both a fresh CentOS 4.4 install on x86
(not x64, to rule that out) using built-in RHEL packages; and on the
original x64 server when compiling from sources (with sys quotas and
disk quotas enabled or disabled).

As I say I can see the quota correctly on the Samba server using the
unix quota command but on the windows client the samba mapped drive
shows entirely the wrong value as free/used. If I make the home
directory on a local disk which doesn't use quotas all is fine.

Am I missing something really obvious?

Kind Regards,


> -----Original Message-----
> From: samba-bounces+steve-lists=aston.ac.uk at lists.samba.org
> [mailto:samba-bounces+steve-lists=aston.ac.uk at lists.samba.org] On
> Behalf Of Steve Goodman (lists)
> Sent: 15 December 2006 15:42
> To: samba at lists.samba.org
> Subject: [Samba] Samba and NFS quota problem
> Hello,
> I am mounting via NFS a number of volumes and re-sharing these as
> We have been using this arrangement successfully for a number of
> We are replacing the "CIFS>NFS" proxy servers (which are also PDC/BDCs
> to OpenLDAP) and a weird problem seems to occur.
> The problem is the quota/disk size appears to be wrong. For example,
> I use the unix quota command on the SMB server, it shows correctly the
> quota and usage. However on the windows machine this is showing
> incorrectly. The NFS is mounted with no special options, and I have
> tried against different NFS servers, different Samba versions and can
> replicate the problem on both the PDC and BDC servers (which are setup
> identically)
> OS:
> CentOS 4.4 x64
> Hardware:
> Dell Poweredge 2950
> Current Samba version:
> samba3-client-3.0.23d-30
> samba3-3.0.23d-30
> (Also occurs on CentOS/RHEL Samba-3.0.10)
> NFS server:
> Solaris 9, default settings. Also it shows the wrong quota information
> using another NFS server (EMC Celerra NAS 5.5)
> Quota shows correctly using quota command:
>      Filesystem  blocks   quota   limit   grace   files   quota
> grace
> helios:/adm/d501
>                  359519  500000  500500             668       0
> Disk usage on the windows system shows:
> 8.98MB free of 265MB - writing any file to this fails.
> Samba also appears to be compiled with quota options enabled:
> # smbd -b| grep QUOTA
> Any thoughts on this problem would be greatly appreciated. I am about
> to
> compile from source to see if this still occurs.
> Steve Goodman
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list