[Samba] ACL issue with Samba 2.0.23d + GFS

Dex Chen dex.chen at crosswalkinc.com
Wed Dec 13 22:57:50 GMT 2006

I build with ACL support and installed samba 2.0.23d on RedHat EL 2.6.9.
It runs fine. But, I ran into an issue with ACL support.  Here is the
I set up a cifs share (gfs_cifs) which is on Linux GFS (see the smb.conf
below), and mount it on a XP box. Then I try to change the permission of
the dir through Windows native security tab. When I apply the changes
(click on OK/Apply button), "Unable to save permission changes ...
Access is denied" error message is popped up. 

But, I was able to using "setfacl" command on linux to modify the acl of

In addition, I was able to do exactly same thing for a share (ext_cifs)
on ext3 file system.

At this point, it seems to me this problem has something to do with
combination of samba and GFS.

I tried all other options in smb.conf, and nothing is help.

Any help on this would be really appreciated.




   workgroup = lab01.local
   netbios name = CUB02
   server string = cub01 Samba Server
   printcap name = /etc/printcap
   load printers = yes
   cups options = raw
   log file = /var/log/samba/%m.log
   max log size = 50
   local master = no
   preferred master = no
   os level = 0
   security = user
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   dns proxy = no
   template shell = /bin/false
   winbind use default domain = yes
   idmap uid = 50000-60000
   idmap gid = 50000-60000
   template homedir = /home/winnt/%d/%u
   template shell = /bin/bash
   encrypt passwords = yes
   acl compatibility = win2k
   comment = test cif shares from Ext3
   path = /var/tmp/ext_cifs1
   public = no
   writable = yes
   dos filemode = yes
   comment =  test cif shares from GFS
   path = /mnt/volume1/export/gfs_cifs1
   public = no
   writable = yes
   dos filemode = yes

More information about the samba mailing list