[Samba] /home vs. /homes vs. [%U]

Linda W samba at tlinx.org
Tue Aug 29 02:15:02 GMT 2006

I've run into a bit of a peculiarity with exporting home directories

and what they map to.

I'm running SuSE samba-3.0.23b-0.1.35.

I have partition /home, with usernames on my linux box.
Am running in "user security" mode.

I'd like to be able to not only access my home directory, but
the parent as well (/home).  Some of the /home directories are
"software project homes" instead of user homes. So I'd like to
be able to cd into /home/projects, for example.

On the server, I've exported the home directory 3 different ways (trying
to find one that would work).

I have [homes] with path of "/home", comment "All Users Home"
I have [home] with path of "/home/%U" comment "Home directory"
and [%U] with path of "/home/%U" comment "Home directory".

Running "smbtree", on the server I see:
               \\SERVER\homes                  All Users Home
               \\SERVER\home                   Home Directory
               \\SERVER\user                   Home Directory

Seems ok so far.  But the problem:  on my XP client,
accessing   gives  this server path:
\\server\homes  ->      \home\userhome
\\server\home   ->       "empty"
\\server\%U     ->      \home\userhome

For some reason "my share named "/homes" is mapping me to my
user directory, while /home maps to "nada?"

I'm guessing maybe "/homes" is a special name reserved for
user home dirs and it will automatically map a user to
their home directory?

Why would //ishtar/home map to nothing?

It appears that \\server\homes is the "all users Home" with
   path "/home" (but not from an xp client)
And it looks like \\server\home maps the way I want it to from
"smbtree" on the server.  But on the client, it gets a blank?
I've even tried matching "/home" to "/home", but that's turning up
empty as well (could it be a cached empty directory?)

Anyone else tried to setup the ability to access "/home" (the dir)
above the user's dir?


More information about the samba mailing list