[Samba] samba-3.0.23a: NT_STATUS_BAD_NETWORK_NAME and swat: no log out button (?)

psihozefir sorin.panca at gmail.com
Wed Aug 2 07:06:11 GMT 2006

Hello! I have two questions regarding SWAT.
1) Where is the logout button?
2) How can I set administrative privileges for a user ?


And a problem with samba:
I run gentoo linux, the test version and since my last upgrade to
samba-3.0.23a I can't access my server.

Until yesterday WindowsXP from another host tried to log in. The log
in window asked for a username and a passoword. After that an error
occured stating that the server could not authenticate the user. Today
I get no login window and the error is 'network path could not be
found'. The error displays after a short time after I run the command
\\ If I stop the service, I get the same error. but after
waiting for a while.

When I try to smbclient -L -U laser (laser is an ordinary user) I get
sorin at zefir ~ $ smbclient -L -U laser
Domain=[ZEFIR] OS=[Unix] Server=[Samba 3.0.23a]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME
This happened yesterday and still happens today.

No config was changed since it worked. (No conf file, no permissions,
no deleted directories, etc)

Here is my smb.conf and smbusers:

# smb.conf
server string = Network Server
netbios name = ZEFIR
interfaces = lo, eth2, eth3
#obey pam restrictions = Yes
#passdb backend = tdbsam, guest
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n .
log file = /var/log/samba/log.%m
max log size = 1000
printcap name = cups
security = user
preferred master = no
local master = no
domain master = no
dns proxy = no
wins support = Yes
panic action = /usr/share/samba/panic-action %d
write list = @wheel @admin
restrict anonymous = no
workgroup = LaserNet
max protocol = NT
ldap ssl = No
server signing = Auto
socket options = IPTOS_THROUGHPUT
bind interfaces only = no
#hosts allow =
#hosts deny = ALL
time server = yes
follow symlinks = no
read only = no
msdfs proxy = no
wide links = no
inherit permissions = yes
fake oplocks = no
admin users = sorin, root

valid users = sorin,laser
hide files = portage-tmp/sorin.jpg/styles.xml/test/date_personale/content.xml/backup.root/Gestiune.ods/DC++/html.tar.gz/
veto files = html.tar.gz/portage-tmp/sorin.jpg/styles.xml/test/Gestiune.ods/backup.root/content.xml/date_personale/
username = sorin laser
path = /date
read only = yes
comment = Datele lui Sorin

comment = DO NOT ENTER !!!
path = /home/date
valid users = sorin,wiorel
admin users = sorin,wiorel

path = /home/date/dl/
comment = Fisiere luate cu torrent.

path = /home/date/Torrente/
comment = Aici pui fisiere .torrent ce trebuie downloadate.

path = /home/date/Poze
comment = Poze de retea.

path = /home/date/Faze
comment = Filmulete si poze cu faze faine.

path = /home/date/Filme
comment = Filme.

path = /home/date/Jocuri
comment = Kituri pentru jocuri.

path = /home/date/Kit
comment = Kituri de programe.

path = /home/date/Reclame
comment = Filmulete si fisiere audio cu reclame faine.

path = /home/date/Videoclipuri
comment = Videoclipuri.

path = /home/date/Doc
comment = Documente scrise.

path = /home/date/Imagini_CD
comment = Imagini de DVD, CD si alte componente (nu-i vorba de poze!).

path = /home/date/Retea
comment = Chestiuni de retea

path = /home/date/full
comment = Full access

# smbusers
# Unix_name = SMB_name1 SMB_name2 ...
# $Header: /var/cvsroot/gentoo/src/patchsets/samba/configs/smbusers,v
1.1 2005/08/09 12:56:26 seemant Exp $
root = administrator admin sorin wiorel
nobody = guest pcguest smbguest

Please give me an advice. Thank you!

More information about the samba mailing list