[Samba] file transfer problem

Hans du Plooy hansdp-lists at sagacit.com
Sat Apr 22 09:27:22 GMT 2006

On Mon, 2006-04-10 at 22:14 -0500, Elvar wrote:
> I'm having a problem copying large amounts of data from our Win2k3 
> server to a samba share on the samba server. I've turned debugging on in 
> the smb.conf file all the way up to level 10 and I still do not see what 
> is causing my file transfers to abort. It consistently aborts copying 
> files as small as 10 gigs even. I've read through the performance tuning 
> section in the handbook and tried those options, but I'm still not 
> having any luck. I tried copying the same data using ftp instead and did 
> not have any problems so I do not think there is a physical networking 
> problem. If anyone has any suggestions I would greatly appreciate them.

Elvar, have you had any luck with this?  I'm having the same problem.
NTbackup can write an 82gb file to the samba box, but I cannot copy it
back to the Windows 2000 server to put it on an external drive to take
it off-site.

It doesn't happen between two win2k servers, and if I mount the samba
share on another linux server, it also doesn't happen.  But it happens
between windows and samba, which leads me to believe it's an
interoperability issue of sorts.

I've updated the kernel, the network card driver (tg3 for a broadcom
gigabit) as well as samba.

Something else I notice, is if I copy via the samba server's onboard
crappy 100mbit network, the problem doesn't occur.  So I wonder if
there's a transfer setting of sort that causes problems at high transfer
rates that needs to be backed off a bit?


More information about the samba mailing list