[Samba] Weird XP synchronisation issue. Using old cached IP?

Paul Smith paul at gami.com
Mon Apr 10 16:10:33 GMT 2006

First, a little background:
I successfully migrated the samba PDC funtionality from an old Suse
machine to a new debian-based one.  The old machine was named PHOENIX
and had an ip address of  The new one has the same name but
is on
Everything is working just fine with this new domain (authentication,
adding users, computers, printing etc), except for one laptop.
Since the domain changeover I've assigned the old IP address
to a machine running MS Project Server 2003 which works just fine.

Now, the issue:
When the XP-based laptop attempts to synchronise its offline files it
prompts me for a username/password, but the server name in the login
dialog is PROJECTSRV - the name of the ProjectServer at

I have tried to rectify this by bringing down the ProjectServer, adding
an ip eth0.alias to the samba PDC of and synchronising the
laptop.  This worked fine.  However, when I remove this ip alias and
bring the ProjectServer back online, the synchronisation error occurs
again.  I've searched the registry on this laptop for and
PROJECTSRV but have found nothing.

Has this happened to anyone before?  How can I reset the laptop's
synchronisation configuration to only want to synchronise with PHOENIX?



More information about the samba mailing list