[Samba] Not able to join domain

Eric Hines eehines at comcast.net
Thu Apr 6 14:40:05 GMT 2006

At 04/06/06 09:18, Chris Boyd wrote:
>I ran the groupmap script
>net groupmap modify ntgroup="Domain Admins" unixgroup=ntadmin
>net groupmap modify ntgroup="Domain Users" unixgroup=users
>net groupmap modify ntgroup="Domain Guests" unixgroup=nobody
>  and was able to create the root account in pdbedit.
>I've gotten the XP machine to join the UCD domain now. Although I'm 
>still not clear what the groupmapping did.

It created a confluence of Windows admin and *NIX root.  This allows 
either to be used in place of the other, but now things get hazy for 
me, and a Samba guru is going to have to supply clarity.  I'm nearly 
as new at this as you.

> >
> > Ok I've got it back to PDC by doing the "net rpc join PDC.It
> > gave me a failed to join domain error but it shows as a
> > domain PDC now.
>That syntax would be right if you were trying to join a domain called "PDC"
>Showing as PDC is only dependent of the smb.conf file.

According to my man page, this is the correct syntax for joining as 
PDC, not joining a domain called PDC.  Setting <domain logons = yes> 
should make Samba be the PDC, also, but I've had trouble with this 
absent explicitly joining the domain as PDC, also, using the above 
command.  This is either a bug in Samba (I've been using 3.0.14 and 
3.0.21a), or it's a function of my newness and error rate at setting 
up samba servers.  I lean toward the latter.

The mode in which the inevitable comes to pass is through effort.
         --Justice Oliver Wendell Holmes, Jr 

More information about the samba mailing list