[Samba] Re: Run away samba, and free() errors

Steve A gmane at rowyerboat.com
Thu Apr 6 00:03:57 GMT 2006

Hi Terry,

Check this out... (from your message)

     In-Reply-To: <e11gbi$d59$1 at sea.gmane.org>

And from my message (completely different topic)...

     Message-ID: <e11gbi$d59$1 at sea.gmane.org>

You should always create a new post, not reply to an existing one by 
changing the subject, otherwise your message will get threaded incorrectly, 
and most likely not answered.

And I'm sorry - I don't know the answer to your question.

Steve :)

Terry Hardie wrote:
> Hi,
> I'm running samba 3.0.22, and have reproduced this issue in 3.0.14a as
> well. I am trying to access a network share with a large number of
> long directory names (up to around 80 characters), with around 1100
> of these directories. Some times it works, but most of the time, the
> windows machine (running windows server 2003) never gets the listing.
> It seems to try to reconnect, and samba starts another smbd.
> Even though I have "max smbd processes = 100", after a while, I end up
> with 1000's (I'm not exaggerating) of smbd's. Also, in the logs for
> smbd, this is showing up:
> *** glibc detected *** free(): invalid pointer: 0xb7edbc38 ***
> I've seen a few other people complaining about this. I've tried the
> backup/verify of the .tdb's - didn't find any problems. I've also
> tried upding my glibc to the latest version (now running 2.3.6).
> Help?
> ---
> Terry Hardie terry at net.com
> SHOUTip System Architect & Principal Engineer ICQ#: 977679
> net.com, 6900 Paseo Padre Parkway
> Fremont, CA 94555, USA V: +1-510-574-2366 

More information about the samba mailing list