[Samba] Samba authenticating, but not against domain

Daniel Baughman dan at pbrnow.com
Wed Sep 21 18:54:12 GMT 2005

Hi again

I think I have found part of my problem.  When I run a 'getent passwd'
command the password type field of the domain users all have * instead of x.

Has anyone seen that before?
-----Original Message-----
From: samba-bounces+dan=pbrnow.com at lists.samba.org
[mailto:samba-bounces+dan=pbrnow.com at lists.samba.org] On Behalf Of Daniel
Sent: Wednesday, September 21, 2005 10:27 AM
To: samba at lists.samba.org
Subject: [Samba] Samba authenticating, but not against domain

I'm running samba 3.0.10 on a fedora core 3 box.  I am trying to get the
thing setup as a member server in our NT domain such that I can specify
domain users in the "valid users" directive under each share.

I believe I need to use winbind to do this effectively for a large domain.
Runing getent passwd does list all of the domain users.  I believe I have
the system joined to the domain.  I added the server through the windows NT
server manager, and then ran the NET rpc join command.

I think I am joined to the domain properly, but somewhere my authentication
configuration is screwy.

I can't get people authenticated against a share, even if they are listd as
a valid user under that share in the smb.conf, unless I run smbpasswd -a
<username> and then specify a password.  This defeats the purpose, as I the
password isn't synched with the NT domain.

Any Suggestions?

Dan Baughman

To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list