[Samba] result was WERR_ACCESS_DENIED

James Watkins misterwatto at gmail.com
Mon Oct 17 11:22:15 GMT 2005

I think I'm having a similar problem to you and I've had no reply as yet 
(except an out-of-office one) to my post.
I think it's just an authentication problem.  I've got security = domain 
and I'm guessing that since the user 'root' is not present in my domain 
(and even if it was it wouldn't necessarily have any clout on the samba 
print server anyway), logging into the samba server as root doesn't give 
you the permissions to do 'setdriver'.  I've tried adding a domain user 
(DOMAIN\USER style) into the 'printer admin' option for the Printers 
share.  I've tried adding my domain user to a local group (ntadmins) and 
adding @ntadmins to the 'printer admin' option.  I've tried using 'net 
rpc rights grant...' to give print management rights to my domain user. 
  Still no joy.  I've decided to change to 'security = server' in the 
hope that I can then get the printers configured as I want them before 
changing back to 'security = domain' but I haven't had the time to do 
this yet.  I'd like to know if there is a more elegant solution (if 
indeed my proposal is a solution) so I'd like to know if you've found 
out anything useful.


E. Dandrades wrote:
> Anyone know what this means and how to fix it?
> Thanks.
> Running command: rpcclient -N -U'root%password' -c 'setdriver HPPRINTER HPPRINTER'
> Connecting to host=
> Connecting to at port 445
> Doing spnego session setup (blob length=58)
> got OID=1 3 6 1 4 1 311 2 2 10
> got principal=NONE
> Got challenge flags:
> Got NTLMSSP neg_flags=0x608a0215
> NTLMSSP: Set final flags:
> Got NTLMSSP neg_flags=0x60080215
> NTLMSSP Sign/Seal - Initialising with flags:
> Got NTLMSSP neg_flags=0x60080215
> lsa_io_sec_qos: length c does not match size 8
> SetPrinter call failed!
> Password for root required to access via SAMBA: 

More information about the samba mailing list