[Samba] winbindd and user groups

Strebel, Franz R. strebelf at who.int
Tue Nov 15 09:14:05 GMT 2005


I'm using samba 3.0.20b with security=domain and my server
is part of an NT 4.0 domain which trusts another domain being
run on AD mixed mode.  Accounts on samba are handled by

Here's the problem:  I asked the admin of the trusted domain to
create a new domain group and add several users to it.  However,
after a couple of days, the group exists on my samba server
but a couple of accounts are still not seen as group members.
What's even more bizarre is that when I compare group membership
of those two accounts between the samba server and the trusted
domain, the listings are identical except for the new group.  So
on samba, they are members of let's say group A, but on the domain,
they are not and are instead members of group B (the one that 
was just created).

I've tried stopping the the samba server and deleting the winbind
cache in the locks directory to no avail.  Any ideas as to why this
is happening?


More information about the samba mailing list