[Samba] Group mapping giving incorrect GIDs

Adam Nielsen adam.nielsen at uq.edu.au
Thu Nov 10 01:58:22 GMT 2005

Hi Eric,

Thanks for your reply!

> In my case, I was trying to use a mapped group on "valid users =
> @mapped".  That does not work at all.

Hmm, it looks like there are a few places where it would be good to
include the group mapping functionality.

> I also could not make it work with ACLs.

Ah - that was my next avenue if I couldn't get this to work :-(

> A co-worked did some additional testing and could get mapped groups
> to work on ugo permissions, but only with "security = user", not
> "security = ads".

Oh ok, I tried security = user, but then I couldn't log on with domain
accounts.  Interestingly enough, even with security = server I couldn't
either.  I don't have ADS support compiled in, so I'm using
security = domain.

> If my co-worker and I can characterize the behavior more accurately, 
> I'll write up what we find for posterity.

I'll be very interested to hear if you discover anything!

Thanks again,

More information about the samba mailing list