[Samba] system-config-samba, error

Tony Earnshaw tonye at billy.demon.nl
Thu Mar 24 01:50:26 GMT 2005

Mauricio Silva:

> Hello i am new using samba, and i need some help.
> First this is my system:
> Fedora C3 (2.6.10-1.770_FC3)
> Samba-3.0.10-1.fc3
> system-config-samba-1.2.28-0.fc3.1
> Well i started to use samba, and everything worked fine, but u updated
> my system and there samba stop working, i cant access to the paths that
> before i used to access, i looked to the smb.conf , and everything is ok,
> as well the smbpasswd and smbusers.
> When i try to run the GUI of samba server, it doesnt load, when i try
> to do it by shell
> [root at mty00 ~]# system-config-samba
> I got these errors:
> Traceback (most recent call last):
> File "/usr/share/system-config-samba/system-config-samba.py", line 41, in
> ?
> mainWindow.MainWindow(debug_flag) File
> "/usr/share/system-config-samba/mainWindow.py", line 79, in __init__
> self.samba_data = sambaParser.SambaParser(self) File
> "/usr/share/system-config-samba/sambaParser.py", line 177, in __init__
> self.parseFile() File "/usr/share/system-config-samba/sambaParser.py", line
> 215, in parseFile
> token = self.createToken(line, section) File
> "/usr/share/system-config-samba/sambaParser.py", line 264, in
> createToken token =
> sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL, (name,
> value)) File "/usr/share/system-config-samba/sambaToken.py", line 63, in
> __init__
> raise AttributeError, value AttributeError: ('dead time', '0')

I'm a RHAS3 sysadmin; everything that Red Hat has to do with Python craps
out on updates of every sort.

Do NOT run the Red Hat Samba GUI, it's useless anyway, run SWAT - if you
have to use any GUI at all - which you definitely should not. God did not
invent vi/(bash|ksh)/awk/sed for nothing ;)

> If i run this command
> service smb status smbd (pid 21969 21965) is running... nmbd (pid 21970) is
> running...
> if i restart the service, everything goes ok, but still cant enter to
> directories, i tried to reinstalling but it doesnt work,  i got the same
> error.
> Does anyone know how to fix this?


> am i doing something wrong?


> is this a bug?

It is no doubt a Fedora bug. If you stick to what is in the Samba .pdf
docs and *everything* that is written in them, including the appendices,
you will get your system working again. Most Red Hat system configuration
GUIs are worthless and using many of them at all can/probably will
completely ruin your system. Unless you make a real effort to understand
complicated software such as Samba (also Postfix, OpenLDAP, SQL and
others) from the bottom up, you can never expect things to work.


mail: tonye at billy.demon.nl

More information about the samba mailing list