[Samba] system-config-samba, error

Mauricio Silva crotar at gmail.com
Wed Mar 23 22:29:26 GMT 2005

Hello i am new using samba, and i need some help.
First this is my system:

Fedora C3 (2.6.10-1.770_FC3)

Well i started to use samba, and everything worked fine, but u updated
my system and there samba stop working, i cant access to the paths
that before i used to access, i looked to the smb.conf , and
everything is ok, as well the smbpasswd and smbusers.

When i try to run the GUI of samba server, it doesnt load, when i try
to do it by shell

[root at mty00 ~]# system-config-samba

I got these errors:

Traceback (most recent call last):
   File "/usr/share/system-config-samba/system-config-samba.py", line 41, in ?
   File "/usr/share/system-config-samba/mainWindow.py", line 79, in __init__
     self.samba_data = sambaParser.SambaParser(self)
   File "/usr/share/system-config-samba/sambaParser.py", line 177, in __init__
   File "/usr/share/system-config-samba/sambaParser.py", line 215, in parseFile
     token = self.createToken(line, section)
   File "/usr/share/system-config-samba/sambaParser.py", line 264, in
     token =
sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL, (name,
   File "/usr/share/system-config-samba/sambaToken.py", line 63, in __init__
     raise AttributeError, value
AttributeError: ('dead time', '0')

If i run this command

service smb status
smbd (pid 21969 21965) is running...
nmbd (pid 21970) is running...

if i restart the service, everything goes ok, but still cant enter to
directories, i tried to reinstalling but it doesnt work,  i got the
same error.

Does anyone know how to fix this? am i doing something wrong? is this a bug?

More information about the samba mailing list