[Samba] WinXP "deletes" but file still there - no error returned

Markus Kofler markus.kofler at gmx.at
Sat Mar 19 01:40:11 GMT 2005

Hi all,

(posting out of /etc/samba/smb.conf)

path = /mnt/storage/samba/mp3new
valid users = @smb-user
read only = No

Unix-Permissions on that folder:
drwxrwx--T 2 root smb-user 4096 18. Mär 22:55 mp3new

In this folder is one file for testing: (x.mp3)
-rw-r--r-- 1 admin smb-user 0 18. Mär 22:55 x.mp3

User admin belongs to group smb-user and user
testuser belongs to smb-user as well.

When I access the Samba-Server from a WinXP-Prof-Client
using the testuser I can "delete" the file, allthough sticky bit is set
and I'm NOT the owner of it. Windows deletes it.
I looked into linux but the file is still there/available. (logical! - 
sticky bit is set!)

Then I press i windows in the explorer F5 (to actualize my view) and the
file is there once again! Why do I don't get an error-message, that the file
CAN'T BE deleted like in unix? I tried also to rename the file via windows.
That doesn't worked and I got a error-msg! But "deleting" works... (ok, 
the file
is still there....)

Post available as well at: 


More information about the samba mailing list