[Samba] AIX/Samba vs. Large Files

Cameron Hanover chanover at umich.edu
Wed Mar 9 13:23:00 GMT 2005

I'm having trouble getting Samba 3.0.11 working properly on AIX  I've got a share set up, and I can connect fine, but I can't 
get it to transfer files >1GB.  I've already set ulimit fsize to -1, 
and I can transfer large files via scp to the same directory just fine. 
 The directory is on a JFS volume.  There are no quotas on this system. 
  I've even tried adding -D_LARGE_FILES to the cppflags [there was one 
google hit that mentioned that].  The log files tell me nothing [with 
loglevel ranging anywhere from 1-5].  The Max Volume Size is set to 0.  
When the configure script is run, it says "checking if large file 
support can be enabled... yes".  According to config.log: #define 

When I try it from OS X, it'll transfer until it hits 1GB, then it'll 
report the disk is full, and delete the file.  From command line 
smbclient, it does the same, but doesn't delete the file, and tells me 
"NT_STATUS_DISK_FULL".  From Windows XP, it just reports that there's 
not enough space before the transfer starts.  The disk has 13GB free.  
I've also tried 3.0.9 and got the same results.

Any thoughts on what I could try next?


So shines a good deed in a weary world.

More information about the samba mailing list