[Samba] AIX/Samba vs. Large Files

William Jojo jojowil at hvcc.edu
Wed Mar 9 13:43:04 GMT 2005

On Wed, 9 Mar 2005, Cameron Hanover wrote:

> I'm having trouble getting Samba 3.0.11 working properly on AIX
> =A0I've got a share set up, and I can connect fine, but I can't
> get it to transfer files >1GB. =A0I've already set ulimit fsize to -1,
> and I can transfer large files via scp to the same directory just fine.
> =A0The directory is on a JFS volume.  There are no quotas on this system.
>   I've even tried adding -D_LARGE_FILES to the cppflags [there was one
> google hit that mentioned that].  The log files tell me nothing [with
> loglevel ranging anywhere from 1-5].  The Max Volume Size is set to 0.
> When the configure script is run, it says "checking if large file
> support can be enabled... yes".  According to config.log: #define

What does your /etc/security/limits look like?

Also did you create the FS with large file support? JFS by default does
not have this turned on. Did you create this with mkfs or smit?

If it was mkfs the "-o bf=3Dtrue" needed to be used and the fragment size
must be 4096.


> When I try it from OS X, it'll transfer until it hits 1GB, then it'll
> report the disk is full, and delete the file. =A0From command line
> smbclient, it does the same, but doesn't delete the file, and tells me
> "NT_STATUS_DISK_FULL". =A0From Windows XP, it just reports that there's
> not enough space before the transfer starts. =A0The disk has 13GB free.
> I've also tried 3.0.9 and got the same results.
> Any thoughts on what I could try next?
> -c.
> So shines a good deed in a weary world.

More information about the samba mailing list