[Samba] Quickbooks files can't be shared w/ 3.0.11

Adnan Yusuf ayusuf at greaterthanone.com
Thu Mar 3 20:47:00 GMT 2005

I had to use the 'veto oplocks' option since I wanted oplocks for everything else on the share. QB works, but nothing else can even read the file. I get a 'Resource Deadlock Avoided' error on smbclient.

'smbstatus' reports a DENY_NONE lock, and an access mode of 0x2019f. I couldn't find the significance of this anywhere.

Point to note is that the same setup worked fine without any hitches or errors on Samba 2.2.8. This problem only surfaced when I upgraded to 3.0.11.

-----Original Message-----
From: samba-bounces+ayusuf=greaterthanone.com at lists.samba.org
[mailto:samba-bounces+ayusuf=greaterthanone.com at lists.samba.org]On
Behalf Of Randy S
Sent: Thursday, March 03, 2005 3:01 PM
To: Mitch (WebCob)
Cc: samba at lists.samba.org
Subject: Re: [Samba] Quickbooks files can't be shared w/ 3.0.11

I had to add these to the share to get that working properly. I've 
probably added some stuff that's not needed, but it worked, so I left 
it. I think the oplocks  setting is key though.

    create mask = 0777
    force create mode = 0777
    oplocks = no
    force directory security mode = 0777

Mitch (WebCob) wrote:
> The second instance of Quickbooks shows a "file may be corrupt" message.
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list