[Samba] [SOLVED] Samba 3.0.11 doesn't work on Fedora Core 2

Philip Burrow philburrow at blueyonder.co.uk
Tue Mar 1 13:07:37 GMT 2005

Philip Burrow wrote:
> Andrew Bartlett wrote:
>> I think it's a bug in the version of nss_ldap included in FC2.  I run
>> with this patch (removing an optimisation in our handling on LDAP).
>> Perhaps the smbldap part of the changes are not required...
> Hi Andrew,
> What I have found is that 3.0.10 works fine on Fedora 1 and 2, but 
> 3.0.11 and the 3.0.12 prerelease suffers the issue described by me 
> earlier and by Dimitry here. I built from SRPMS provided on samba.org in 
> all cases.

Just following up my own post, I obtained nss_ldap-220-3.src.rpm (used 
in FC3) for a FC1 machine, built and installed it then rebuilt Samba 
3.0.12pre1 and installed.

This appears to have fixed the problem. I was using nss_ldap-217-1 on 
both my FC1 and FC2 machines, hence why it wasn't working on both. I 
since tested 3.0.11 and it worked too.

Thanks Andrew for your comments.


More information about the samba mailing list